Major problems on Voice of the Customer - online reports
Incident Report for Bisnode
Resolved
This product is no longer part of Dun & Bradstreet and was not removed correctly from this status page. We apologize for the inconvenience.
Posted Jan 15, 2024 - 13:25 EET
Investigating
Bisnode service is currently facing major problems. We are investigating the issue and trying to fix it as soon as possible.
Posted Jan 13, 2024 - 23:36 EET