Major problems on Voice of the Customer - online reports
Incident Report for Bisnode
Resolved
Issues has been resolved. Voice of the Customer - online reports service is currently running normally.
Posted 6 months ago. Dec 03, 2018 - 01:29 EET
Investigating
Bisnode service is currently facing major problems. We are investigating the issue and trying to fix it as soon as possible.
Posted 6 months ago. Dec 03, 2018 - 01:27 EET
This incident affected: Verkkopalvelut / Reporting services (Voice of the Customer - online reports).