Major problems on Voice of the Customer - online reports
Incident Report for Bisnode
Resolved
Issues has been resolved. Voice of the Customer - online reports service is currently running normally.
Posted Jun 12, 2021 - 02:40 EEST
Investigating
Bisnode service is currently facing major problems. We are investigating the issue and trying to fix it as soon as possible.
Posted Jun 12, 2021 - 02:33 EEST
This incident affected: Verkkopalvelut / Reporting services (Voice of the Customer - online reports).