Major problems on Bisnode RiskGuardian -luottotietopalvelu - Bisnode RiskGuardian Credit Service
Incident Report for Bisnode
Resolved
This incident has been resolved and we apologize for the inconvenience.
Posted Sep 14, 2023 - 07:50 EEST
Investigating
Bisnode service is currently facing major problems. We are investigating the issue and trying to fix it as soon as possible.
Posted Sep 14, 2023 - 00:52 EEST