Major problems on Voice of the Customer - online reports
Incident Report for Bisnode
Resolved
Issues has been resolved. Voice of the Customer - online reports service is currently running normally.
Posted Nov 24, 2021 - 06:31 EET
Investigating
Bisnode service is currently facing major problems. We are investigating the issue and trying to fix it as soon as possible.
Posted Nov 23, 2021 - 23:43 EET