Major problems on Bisnode RiskGuardian -luottotietopalvelu - Bisnode RiskGuardian Credit Service
Incident Report for Bisnode
Resolved
this incident has been resolved, we apologize for the inconvenience.
Posted Sep 15, 2023 - 11:42 EEST
Investigating
Bisnode service is currently facing major problems. We are investigating the issue and trying to fix it as soon as possible.
Posted Sep 15, 2023 - 09:10 EEST